Home Update - 25 Jun 2024 User PageKnow-how

Configuration Settings

Creo Parametric and Pro/ENGINEER

環境設定ファイル config.pro

 環境設定ファイルは Creo Parametric(Pro/ENGINEER) の実行環境を制御するために使用します。

 全員が共通で使用する設定は『[Creo(Pro/E)をインストールしたディレクトリ/text/config.pro]に保存しておきます。Creo(Pro/E)を起動すると、このディレクトリにある[config.pro]が自動的に読み込まれ、その記述内容に従って動作環境が設定されます。一時的に設定を変更したい場合は共通の[config.pro]を変更するのではなく、標準設定と異なる項目のみを記述した環境設定ファイル、例えば[config_pro01.pro]を自分のワーキングディレクトリ内に作成し、必要な時に下記の操作をします。

  • Creo Parametric - ファイル/オプション/コンフィグレーションエディタ/コンフィグレーションファイルをインポート/例えば[config_pro01.pro]を読みこむ
  • Pro/E Wildfire - メインメニューから ツール/オプション/コンフィグレーションファイルを開く/例えば[config_pro01.pro]を読みこむ。

 但し、Creo Parametric(Pro/E Wildfire)を起動した後では変更できない項目もありますから、注意して下さい。

 設定項目はマニュアルに記述されているだけでもかなりの量ですが、ざっと目を通しておくことをお薦めします。「こんなことができればいいのに」と思っていることが意外と簡単に実現できたりします。また、マニュアルに記述されていない項目(隠しオプション)もありますので、あきらめないでサポートに電話してみましょう。

 私がコンサルティングやセミナで使用している環境設定は下記のファイルをダウンロードして下さい。あまり特殊な設定はしていませんが、会社で使用する場合は社内のルールに従って、設定内容の変更をお願いします。不具合がある場合は連絡いただければ、できる限り対応させていただきます。無償で公開していますので、みなさんと一緒により良いものにしていければと思っています。

 ダウンロードした zip ファイルのパスワードは gah01300@sannet.ne.jp まで、お問い合わせ下さい。

  • 「環境設定ファイル一式」 - setup_creo_20240624.zip - 2024年06月24日版
    (注意)ブラウザによっては[安全ではないファイル]という警告が出されますが、安全なファイルとしてダウンロードしてください。
  • 「Creo Parematric 環境設定資料」 - setup_creo_20240625_2P.pdf - 2024年06月25日版 ※「環境設定ファイル一式」にも同梱されていますが、基本的にこちらが最新版となります。
  • 主な変更履歴(すべて記載しているわけではありません)

    • Creo Parametric 全般
      • 20240624 - creo_parametric_customization.ui の軽微な変更です。最新の「Creo Parametric 環境設定資料」を同梱しました。
      • 20240201 - config.pro の設定変更 および Creo10 の環境設定追加(現時点では Creo9 の設定を流用していますが、今後 Creo10 独自の設定があれば追記していきます)
      • 20231001 - 環境設定資料内の説明内容を追記修正しました。軽微な変更です。
      • 20230605 - ユーザ定義材料フォルダ(..setup/materials_user/)を更新しました。
      • 20220624 - 環境設定資料の記載内容を見直しました。

    • (41)Creo Parametric 10.0
      • 20240614 - 近日インストール予定です。(現時点では Creo9 の設定を流用していますが、今後 Creo10 独自の設定があれば追記していきます)
    • (40)Creo Parametric 9.0
      • 20240624 - creo_parametric_customization.ui、部品テンプレート、アセンブリテンプレートの軽微な変更です。最新の「Creo Parametric 環境設定資料」を同梱しました。
      • 20231130 - システムカラー(syscol_creo9.scl)ファイルの軽微な変更です。図面の背景色を見やすくしました。
      • 20231023 - システムカラー(syscol_creo9.scl)ファイルの変更、モデルおよびスケッチャーの寸法背景色を見やすく変更しました。
      • 20230806 - システムカラー(syscol_creo9.scl)ファイル、外観カラーパレット(appearance.dmt)ファイルなどの軽微な更新です。
      • 20230529 - モデルツリー、レイヤツリー、設計ツリーなどの配置を部品、アセンブリ、図面モードで統一しました。
      • 20220406 - モデルツリー、レイヤツリー、設計ツリーなどの配置を見直しました。座標系のチカチカするRGBカラーをオフにしました。
      • 20230222 - ようやくインストールしてみました。基本的には Creo 8.0 の設定を流用しています。
    • (39)Creo Parametric 8.0
      • 20231023 - モデルおよびスケッチャーの寸法背景色を見やすく変更しました。
      • 20220406 - モデルツリー、レイヤツリー、設計ツリーなどの配置を見直しました。座標系のチカチカするRGBカラーをオフにしました。
      • 20220208 - Creo 8.0 のテンプレートファイルを追加、config.pro の設定変更、環境設定資料の内容修正など。
    • (38)Creo Parametric 7.0
      • 20231023 - モデルの寸法背景色を見やすく変更しました。
      • 20210305 - テンプレート部品のデフォルト外観を白色(ref_color_002)に設定しました。デフォルトの濃いグレーよりは見やすいかと思います。カラーパレットファイル[appearance.dmt]も更新していますので、使ってみてください。
      • 20210202 - 部品テンプレート(master_creo7.prt)にデフォルト材料 SS400(steel_low_carbon)を設定しました。図面枠に使用する材料パラメータと互換性を保つためリレーション(material=ptc_master_material)を追加しました。
      • 20210201 - システム外観(背景色・ロックした寸法)を変更しました。以前のバージョンから違和感のないように少しづつ変更していますのでカスタム設定となっています。お気に召さない方はデフォルト設定に戻してください。
    • (37)Creo Parametric 6.0 - 2024年02月01日版を最終として、重大な不都合がない限り新たな更新は行いません。
      • 20231023 - モデルの寸法背景色を見やすく変更しました。
    • (36)Creo Parametric 5.0 - 2024年02月01日版を最終として、 重大な不都合がない限り新たな更新は行いません。
    • (35)Creo Parametric 4.0
    • (34)Creo Parametric 3.0
      • 20231130 - システムカラー(syscol_creo3.scl)ファイルの軽微な変更です。図面の背景色を見やすくしました。
    • (33)Creo Parametric 2.0
      • 20221225 - フィーチャ作成時に材料の追加・除去を自動的に判断する設定[auto_add_remove]を[NO]に変更しました。その他、システムカラー、クイックアクセスツールバーなど、細部の変更。
      • 20220925 - システムカラー(syscol_creo*.scl)を少し変更しました。過去のバージョンから引き継いでいるので、デフォルト設定とは異なっています。デフォルトのカラー設定に戻したい場合は、ファイル/オプション/システム外観/システムカラー/デフォルト を選択します。
      • 20210327 - グラフィックツールバーの位置を画面上部から画面下部のステータスバー内に移動しました。作業エリアが広くなって、画面キャプチャの際もスッキリしていいかなと思います。カラーパレットファイル(appearance.dmt)も見やすい色に少し調整しました。
      • 20210317 - 部品およびアセンブリのビュー方向をユーザデフォルト方向に向けるマップキー[vv]を更新しました。システム標準方向に向けるには[Ctrl]+[D]を使用します。
      • 20210317 - 部品およびアセンブリのビュー方向について、デフォルト方向を不等角投影(trimetric projection)に変更しました。ビュー名は[TRI_TOP]です。標準方向(システムデフォルト)の斜投影よりは作業しやすいと思います。[TRI_TOP]を水平軸に対して180°回転させた[TRI_BOTTOM]も作成してあります。
      • 20210317 - カラーパレットファイル(appearance.dmt)を更新しました。淡色の反射率が高すぎて見にくかったので、少し反射率を落としています。かなり見やすくなったと思いますので、使ってみてください。よく使う色のみ、透明度50%、75%のものも追加しました。
      • 20210317 - 部品テンプレート(master_creoxx.prt)およびアセンブリテンプレート(master_creoxx.asm)の初期レイヤ設定を変更しました。[AXIS]、[CSYS]、[PLN]、[PNT]に加えて、[AXIS_DEF(デフォルト軸)]、[CSYS_DEF(デフォルト座標系)]、[PLN_DEF(デフォルトデータム平面)]、[PNT_CG(重心点)]を追加しています。初期状態では[PLN_DEF]のみ表示しています。
  • 20230113 - そろそろ使われなくなってきているので、Pro/ENGINEER Wildfire の環境設定ファイル一式は削除しました。必要な方は個別にご連絡ください。

標準設定の内容

 境設定ファイル config.pro の設定例を一覧表にまとめました。システムの[デフォルト値](英小文字[カスタマイズ値](英大文字)で表記しています。CAD販売会社が配布している設定例よりも使いやすいと思います。

 私はこの設定で Creo(Pro/ENGINEER)を使用していますが、ハードウェア構成やディレクトリ設定によって異なる部分は各自でアレンジして下さい。。一覧表の中で指定していない項目についてはシステムの[デフォルト値(英小文字)]が使用されますので、全ての項目を記載する必要はありません。ただし、記載してあっても Creo(Pro/E)のバージョンによっては無視される項目があることに注意下さい。

 また、重要な項目については[デフォルト値(英小文字)]であっても、指定するようにしています。これは、モデリング時に一部の設定を変更する必要が生じた場合に変更しやすくするためです。ごく稀にマニュアルの記載内容が間違っているケースもあるので、確実に環境設定を行うという意味もあります。また、先頭に[!]マークの付いた項目は読み込み時に無視(コメントアウト)されます。

 $setup_dir は setup フォルダの場所(例 P:\setup)を示す環境変数です。起動用のバッチファイルで設定(set setup_dir=P:\setup)しておきます。詳細は setup_creo_yyyymmdd_2P.pdf を参照下さい。

! -- Path and Directory --
パスやディレクトリを指定します。この部分はユーザが使用するシステムにより異なりますので、適宜修正して下さい。
drawing_setup_file $setup_dir\dwg\config.dtl 図面設定ファイルの指定。
format_setup_file $setup_dir\dwg\config.dtl 図面フォーマットで使用する図面設定ファイルを指定します。
mdl_tree_cfg_file $setup_dir\tree_wildfire2.cfg
モデルツリーの設定ファイルを指定します。
Pro/E Wildfire 2.0 の場合は tree_wildfire2.cfg を指定します。
Creo 6.0 以降 - モデルツリー設定は[*.ui]ファイルに保存され、起動時に[*.cfg]は読み込まれません。(警告メッセージが出ます)但し、起動後に設定ファイル[*.cfg]をインポートすることは可能です。
pen_table_file $setup_dir\table.pnt ペンテーブルファイルの指定。
plotter_command WINDOWS_PRINT_MANAGER プロッターコマンドの指定。
plot_file_dir C:\temp プロットファイル保存ディレクトリの指定。
pro_colormap_path $setup_dir
カラーマップ(パレットファイル color.map)を保存したディレクトリの指定。
Wildfire 以降 - 外観パレット定義ファイル[appearance.dmt]が使用されます。
pro_dtl_setup_dir $setup_dir\dwg 図面設定ファイル保存したディレクトリを指定する。
pro_editor_command notepad.exe
エディタにメモ帳を使用する。
図面注記の編集などに使い慣れたエディタを使いたい方はここで指定します。
通常はメモ帳[notepad.exe]を指定しておけばよいでしょう。
pro_format_dir $setup_dir\format 図面枠ファイルのあるディレクトリを指定する。
pro_material_dir $setup_dir\materials_user
ユーザ定義材料ライブラリmaterials_user]を指定します。
SS400 など、JISの材料記号で指定できるようにオリジナルの材料ライブラリに追記してあります。
オリジナルの材料定義ファイルは下記にあります。
Creo をインストールしたディレクトリ以下 ..\Common Files\text\materials-library
pro_note_dir $setup_dir\note 注記ファイルのあるディレクトリを指定する。
pro_plot_config_dir $setup_dir プロッタ設定ファイルのあるディレクトリを指定する
pro_symbol_dir $setup_dir\symbol 製図シンボルのあるディレクトリを指定する。
search_path $setup_dir\dwg
サーチパス(図面設定ファイルディレクトリ)
search_path $setup_dir\format
サーチパス(図面枠ファイルディレクトリ)
search_path $setup_dir\master
サーチパス(マスターテンプレートファイルディレクトリ)
search_path $setup_dir\symbol
サーチパス(シンボルファイルディレクトリ)
start_model_dir $setup_dir\master 開始モデルのあるディレクトリを指定する。
system_colors_file $setup_dir\syscol_wildfire2.scl
システムカラーファイルを指定する。
Pro/E 2001 の場合は syscol_2001.scl を指定します。
template_solidpart $setup_dir\master\master_wildfire2.prt
部品のテンプレートファイルを指定する。
2000i2 以降 - Wildfire 2.0 の場合は master_wildfire2.prt を指定します。
template_designasm $setup_dir\master\master_wildfire2.asm
アセンブリのテンプレートファイルを指定する。
2000i2 以降 - Wildfire 2.0 の場合は master_wildfire2.asm を指定します。
template_drawing $setup_dir\master\dwg_a3_view_2001.drw
図面ビュー配置のテンプレートファイルを指定する。
2000i2 以降 - 2001 以降は共通のテンプレートファイルにしています。
trail_dir C:\temp
トレイルファイルが保存されるディレクトリの指定。
ネットワークドライブに設定すると遅くなりますので、必ずローカルドライブに設定します。
最近の主な更新履歴(General Settiings)
  • 20240201 - 保存時の再生設定[regen_solid_before_saver]の設定を[YES]に変更しました。
  • 20231023 - 寸法の背景色[dim_background_color]に関する説明を追記しました。
  • 20230406 - 座表系の表示がcsys_color_rgbRGBカラーで目障りなので単色[NO]に変更しました。
  • 20221225- フィーチャ作成時に材料の追加・除去を自動的に判断する設定[auto_add_remove]を[NO]に変更しました。
  • 20220208 - Creo 8.0 以降、データム平面の3D(シェーディング)表示が可能になりましたが、パフォーマンス低下の要因をなくすため、私は従来どおりの2D(ワイヤフレーム)表示[enable_legacy_datum_planes]を使っています。
  • 20211109 - [step_export_format]の値を[AP214_IS]に変更しました。
  • 20210612 - [def_layer layer_axis]の設定を[def_layer layer_axis_ent]に変更しました。
  • 20210612 - [show_preview_default]の設定を[KEEP]→[remove]に変更しました。Creo 以降と Wildfire 以前で[表示/消去]コマンド使用時の設定値が逆になっているので注意してください。Creo 以降は設定値[remove]で、Wildfire 以前は[KEEP]で、全アイテム非表示がデフォルト、選択したアイテムが表示されます。
  • 20201128 - Creo 7.0 以降、相対精度と絶対精度の選択に関する設定[enable_absolute_accuracy]が廃止され、常に選択可能になっています。
  • 20200607 - 「パイプ」や「N-サイドパッチ」などのフ ィーチャを使用可能にする「enable_obsoleted_features」の説明を追記しました。
  • 20200607 - Creo 4.0 以降は、スケッチを3D方向で開始する設定[sketcher_starts_in_2d no]を試しています。慣れてしまえば、こちらのほうがいいかもしれません。
  • 20200413 - PDF へ出力する際にペンテーブルファイル[table.pnt]を参照する設定[pdf_use_pentable YESを追加しました。
  • 20181216 - スピン・ズーム時のアニメーションに関する設定[max_animation_time][min_animation_steps]を変更しました。スケッチ画面への移行時などに、ゆっくり回転するので、わかりやすいかと思います。
  • 20181022 - prompt_on_exit]の設定を[YES]に変更しました。しばらく、これで運用してみようと思います。
  • 20181022 - [startup_check_for_visualization]の説明を追加しました。起動時にビジュアリアリゼーションコンポーネント(ファイルフォーマットの関連)を確認しません。
! -- General Settings --
一般的な操作環境を設定します。通常は下記の内容で問題ないと思います。Creo(Pro/E)のバージョンによって設定項目が異なる部分もありますが、そのバージョンで無効な項目は無視されます。
! 2button_mouse_mmb_support YES
2ボタンマウスで[操作可能]にします。中ボタンは[Shift]+[左ボタン]で代替可能となります。
Wildfire 1.0 以降 - 画面の移動操作に[Shift]キーを使うようになったので、この項目は無視されます。
accuracy_lower_bound 1e-6
絶対精度の指定最小値を[0.000001]にする。
新規ファイル作成時に、ここで設定した絶対精度値が使用される訳ではなく、あくまでも絶対精度を入力する場合の最小値を設定するだけです。実務では、必要な絶対精度を設定したテンプレートファイルを用いて、新規ファイルを作成します。
allow_anatomic_features YES
評価フィーチャメニューを[使用可能]にします。
2000i 以降 - この設定を行わないと、評価フィーチャが使用できません。まさか、BMXモジュールを買わせるために隠した?のではないのでしょうけど。
allow_move_attach_in_dtl_move yes 製図モードで「移動」と「アタッチ移動」を同時に[行なう]
allow_move_view_with_move YES マウスによる図面ビューの移動を[可能にする]
! allow_old_style_round YES
古い角R(16以前)を[使用可能]にします。
Pro/E 17 以降 - 17 以降の新しい角R(一般ラウンド)コマンドで作成できない場合でも、古い角R(エッジ)で作成できる場合があります。また、16以前に作成された角Rフィーチャを再定義する場合にも必要ですが、通常はコメントアウト[デフォルト値 - no]しておきます。
! allow_sketch_selection NO
外部スケッチをフィーチャの断面として選択[しない]
Wildfire 1.0 以降 - デフォルト[yes]のままだと、外部スケッチが関連無しにフィーチャ断面として選択(コピー)されます。
ang_dim_in_screen YES
角度寸法を画面内の見える位置に移動[する]
auto_add_remove NO
押し出しや回転フィーチャ作成時に材料を追加するか除去(カット)するかを自動的に判断[しない]
Creo 2.0 以降 - 使い込んでくると、材料の追加・除去を自動的に判断(デフォルト)されるのがうるさくなってくるので、ユーザが判断できるようにしました。
auto_regen_views NO
ウィンドウ変更時に図面表示を自動更新[しない]
メインメニューから、ビュー/ビュー再生 を選択するまで画面の描き換えが行なわれませんので、大きなアセンブリや図面を扱う時に便利です。
bell NO 煩いベル音を鳴らしません。
button_name_in_help YES
選択したメニューをヘルプテキストに英語で表示[する]
オリジナルの英語メニューが表示されますので、変な日本語メニューよりも解りやすいときもありますし、マップキー作成時にも便利です。
chamfer_45deg_dim_text JIS 45°面取りの寸法表示に[JIS表記 C ]を使用します。
clock no Pro/Eの作業待ち時間に時計を表示[しない]
color_resolution 0.01 RGBカラーの分解能を[0.01]にします。
compress_output_files no 保存時にファイルを圧縮[しない]
! conf_mouse_anim YES
共有セッションのオブザーブ中、司会者のマウスポインタを 「表示する」
Creo 2.0 以降 - デフォルト値が表示しない 「no」 になっています。
Wildfire 5.0 以前 - デフォルト値が表示する 「yes」 になっています。
create_drawing_dims_only YES
「製図」モードで作成された寸法を全て[図面に保存する]
作成された寸法は図面に保存されますので、製図作成とモデル変更の並行作業がやり易くなります。
csys_color_rgb NO
座標系RGBカラーで[表示しない]
座標系のカラー表示が目ざわりなので、単色に変更しましや。
! def_layer layer_axis axis 作成した[軸フィーチャとコスメティックねじフィーチャ]を全てレイヤ[axis]に入れる。
def_layer layer_axis_ent axis 作成した[軸エンティティ]を全てレイヤ[axis]に入れる。
def_layer layer_csys csys 作成した[座標系]を全てレイヤ[csys]に入れる。
def_layer layer_curve curve 作成した[カーブ]を全てレイヤ[curve]に入れる。
def_layer layer_datum pln 作成した[データム平面]を全てレイヤ[pln]に入れる。
def_layer layer_point pnt 作成した[点]を全てレイヤ[pnt]に入れる。
def_layer layer_surface surf 作成した[サーフェス]を全てレイヤ[surf]に入れる。
default_abs_accuracy 0.01
デフォルトの絶対精度設定(入力)値を[0.01]にする。
部品作成後、設定/精度/相対/[デフォルトの相対精度をキャンセル]/絶対/値入力/[設定したデフォルト値 0.01 でOK]して下さい。
新規ファイル作成時に、ここで設定した絶対精度値が使用される訳ではなく、あくまでも絶対精度を入力する場合のデフォルト値を設定するだけです。実務では、必要な絶対精度を設定したテンプレートファイルを用いて、新規ファイルを作成します。
default_ang_dec_places 3 図面の角度寸法で表示する小数桁数を[3桁]にする。
default_dec_places 3 モデルの全モードで表示する小数桁数を[3桁]にする。
default_draw_scale 1 デフォルトの製図スケールを[1]にする。
delete_after_plotting yes プロット処理後にプロットファイルを[削除する]
dim_background_color MANUAL
3Dモデルの寸法背景色を[手動]で設定する。
Creo 6.0 以降 - 3Dモデルの寸法背景色を手動で設定します。
dim_background_color_rgb 0 0 0
3Dモデルの寸法背景色を黒[0 0 0]とする。
Creo 6.0 以降 - 寸法背景色をRGB値で指定します。
dim_background_trans 50
3Dモデルの寸法背景色の透明度を[50]とする。
Creo 6.0 以降 - 寸法背景色の透明度を指定します。[0]は不透明、[100]は透明となりますが、透明度[50]くらいでいいと思います。
dim_offscreen_limit 1 ウィンドウ外に表示される寸法マージンを[1]にする。
display_full_object_path YES タイトルバーにファイル名の[フルパスおよびバージョン番号を表示する]
display_in_adding_view MINIMAL_WIREFRAME 新しい製図ビューを[最適なワイヤーフレーム]で初期表示する。
display_silhouette_edges NO
シルエット・エッジを[表示しない]
円筒の側面ラインなどを表示しないので、ワイヤフレーム時の画面表示を高速にできます。
display SHADEWITHEDGES
モデルを[エッジ付きシェード]で表示します。
drawing_file_editor PROTAB 「図面」設定ファイル編集に[PROTAB]を使用する。
dxf_export_format 12 DXFファイルのエクスポートバージョンを[12]にする。
dxf_out_drawing_scale YES
DXF、DWGファイルに[面面スケールをエクスポートする]
AutoCAD向けににエクスポートする場合は[YES]に設定。
! dxf_out_stroke_text YES
図面文字をDXFの「線要素」でエクスポート[する]
文字は修正できなくなりますが、DXFデータの文字化けは解消されます。
[dxfio_in_sjis]を[YES]に設定した場合は不要なのでコメントアウト[デフォルト値 - no]しておきます。
dxfio_in_sjis yes
DXFファイルのインポート、エクスポート時の文字コードに[SJISを使用する]
2000i2 以降 - 文字コードの選択が可能となりました。名前はDXFとなっていますが、IGESにも適用されます。

edge_display_quality HIGH

ワイヤーフレームのエッジ精度を[高]にする。
標準[normal]では、小さな円弧は多角形に表示されますが、表示速度が向上します。
enable_absolute_accuracy YES
相対精度と絶対精度の選択を[可能にする]
デフォルトでは相対精度しか選択できませんので、必ず[YES]に設定しておきます。
Creo 7.0 以降 - 廃止されました。[YES]がデフォルトになっています。
enable_legacy_datum_planes YES
データム平面の2D(ワイヤフレーム)表示を[可能にする]
データム平面は従来どおりワイヤフレームで表示されます。
Creo 8.0 以降 - データム平面の3D(シェーディング)表示がデフォルト設定[no]となりましたが、パフォーマンスが低下することや作業性が悪いことから、私は従来どおりのワイヤフレーム表示に設定しています。慣れてくれば、そうでもないかもしれませんので、ここはお好みで。
enable_obsoleted_features YES
「パイプ」や「N-サイドパッチ」などの古いコマンドを[使用可能にする]
Creo 2.0 以降 - 下記の隠しコマンドが使用可能になりますが、リボンメニューには表示されないので、各自ででメニューに追加する必要があります。
・サーフェス間をブレンド(Blend Between Surfaces)
・断面からサーフェスまでをブレンド(Blend Section to Surfaces)
・円錐サーフェスと N-サイドパッチ(Conic Surface and N-sided Patch)
・一般ブレンド(General Blend)
・パイプ(Pipe)
・投影断面ブレンド(Project Section Blend)
・ソリッドフリー形状(Solid Free Form)
・サーフェスフリー形状(Surface Free Form)
! enable_parasolid_export YES
パラソリッド形式のエクスポートを[可能にする]
Wildfire 1.0 - ファイル出力にパラソリッドを選択可能になります。Pro/E Wildfire 2003410、Pro/E Wildfire Student Edition 2003100 ではOKでした。
(注)Wildfire 製造コード 2003051 ではPro/Eが落ちます。
enable_tree_indep YES
モデルツリーをPro/Eのウィンドウから[切り離し可能にする]
Wildfire 1.0 以降 - モデルツリーを単独のウィンドウで表示します。これは是非[YES]に設定しておきましょう。
! family_table_editor PROTAB ファミリーテーブルの編集に[PROTAB]を使用する。
fast_highlight YES
高速再表示を[有効にする]
Wildfire 2.0 以降 - 簡略ハイライトを使用し、より早く再表示しますが、メモリの使用量が増加することがあります。
fasthlr YES 高速隠線処理を[有効にする]
feature_create_auto_begin YES フィーチャ作成時に「定義」ボタンを自動的に[アクティブ化する]
file_open_default_folder WORKING_DIRECTORY
ファイルオープン時[ワーキングディレクトリ]を検索する。
Wildfire 1.0 以降 - Pro/E Wildfire 1.0 以前はデフォルト設定でワーキングディレクトリが検索されていましたが、Wildfire 2.0 以降は My Document が検索されるようになっています。従来どおり、ワーキングディレクトリを検索したい場合はこの設定を追加しておいて下さい。
INTRALINK では[WORKSPACE]を指定します。
file_open_default_view list
ファイルオープン時のダイアログボックスを[リスト表示]にします。
Wildfire 5.0 以降 - リスト表示[list]にするか、詳細表示[DETAILS]にするか、指定できるようになりました。Wildfire4 以前はデフォルトがリスト表示になっており、詳細表示は指定できません。
force_new_file_options_dialog no 「新規ファイルオプション」を [使用しない]
force_wireframe_in_drawings no [表示設定に従って] ビューを表示する(製図)
graphics opengl
グラフィックス環境に[OpenGL] を使用する。
問題のある場合は[WIN32_GDI]を試してみると良い。
! hardware_options SHADING_AND_WIREFRAME
グラフィックスの設定(システムにより異なる)
2000i2 以降 - 無効となります。
! highlight_new_dims YES
図面で新しい寸法を削除又は再ペイントするまで、赤でハイライト[する]
hlr_for_quilts YES  図面の隠線消去にキルトを[含める]
iges_in_dwg_color YES RGB情報を IGES にインポート[する]
iges_out_all_srfs_as 128 サーフェスを IGES の[Bスプラインサーフェス]として出力する。
iges_out_dwg_color YES RGB情報を IGES にエクスポート[する]
iges_out_dwg_line_font YES ユーザ定義の線種をIGESにエクスポート[する]
! iges_out_dwg_pnt_ent YES
図面の点を、IGES点要素としてエクスポート[する]
Wildfire 1.0 以降 - 無効となります。
iges_out_ent_as_bspline TRUE 図面を IGESファイルにエクスポートする時、線や円弧以外のジオメトリを[第3級Bスプライン]としてエクスポートする。
info_output_format TEXT
情報を テキスト形式 で表示する。
Wildfire 1.0 以降 - デフォルトの設定値[html]では、ブラウザウィンドウに表示されます。
info_output_mode both 情報をスクリーンとファイルの[両方に]表示する。
intf_in_use_template_models YES
インポート時にテンプレートモデルを[使用する]
Wildfire 1.0 以降 - インポートしたデータはデフォルトテンプレートに取り込まれます。
intf_out_blanked_entities NO ブランクエンティティはエクスポート[しない]
intf3d_out_extend_surface NO サーフェスを延長[しない]でエクスポートする。
kbd_cmd_abbreviation off 短縮キーボード・コマンドを[使用不可]にする。
load_ui_customization_run_dir YES
実行ディレクトリ内にある UIカスタマイズファイル(.ui)を[ロードする]
Creo 1.0 以降 - 下記の順番で読み込まれます。
(優先1)[creo_parametric_customization.ui]
(優先2)共通の[creo_parametric_customization.ui]ファイルを使用したい場合は、%APPDATA%\PTC\ProENGINEER\Wildfire\.wf\.Settings 以下に保存しておく。
(優先3)[creo_parametric_admin_customization.ui]というファイル名で %common_dir%\text 以下に保存しておきます。
※詳細は[Creo Parametric 環境設定資料]を参照してください。
Wildfire 5.0 以前 - 画面設定ファイル[config.win]を使用します。
lods_enabled YES スピン時にグラフィック表示を荒く[する]
lods_value 50 スピン時にモデルサイズの[50%]程度のエッジはグラフィック表示を省略して荒くする。
logical_objects YES
データベース構造の再構築を[行なう]
2000i2 以降 - 2000i2 より前に作成されたデータを新しいデータベース構造に再構築します。この場合、全てのフィーチャを再生する必要があります。
この処置で、2000i2 以降の新しいメニュー(ダイナミックチェーン、ダイナミックサーフェス)が使用できるようになります。
mass_property_calculate by_request
質量特性の計算は[ユーザの要求に従う]
Wildfire 1.0 以降 - [AUTOMATIC]にすれば、再生時に質量特性が自動計算されますが、パフォーマンスが低下(再生時間が長くなる)します。
Pro/E 2001 以前 - このオプションは無効。全て[by_request]の状態となっています。
make_aux_view_notes YES
補助ビューにビュー名を[追加する]
ビュー名のフォーマットは図面設定[aux_view_note_format VIEW %viewname]などで指定します。
make_parameters_from_fmt_tables YES 図面フォーマットを置き換える時、テーブルに入力する値を[保存し]、新しいテーブルにコピーします。
max_animation_time 0.5
スピン、ズーム時のアニメーション時間を[0.5秒]に設定します。
あまり大きな値にすると、時間がかかって待ちきれなくなります。
mdx_collision_num_triangles 1000
干渉検知のモデル近似に使用するメッシュ三角形の数を[1000]にする。
Creo 2.0 以降 - デフォルト値は[1000]に設定されています。
Wildfire 3.0 以降 - 項目はありますが、デフォルト値の設定は不明です。
! menu_horizontal_hint RIGHT
追加メニューを[右側]に表示する。
Pro/E 2000i2 以降 - 無効となります。
measure_sig_figures 6 測定値を表示する有効桁数を[6桁]にします。
menu_translation yes メニューを[日本語]で表示する。
min_animation_steps 2
スピン、ズーム時のアニメーションステップを[2]に設定します。
あまり大きな値にすると、ゆっくり過ぎて待ちきれなくなります。
minimum_angle_dimension 0.1 寸法の作成で認識できる角度の最低値を[0.1°]とする。
new_parameter_ui YES
パラメータのウィンドを[表示する]
Pro/E 2001 以降 - パラメータの編集がウィンドウ形式で可能です。
new_relation_ui YES
リレーション(及びパラメータ)のウィンドを[表示する]
Pro/E 2001 以降 - リレーションの編集がウィンドウ形式で可能。
nt_cache_dirs YES Windows NT のキャッシュを[有効にする]
open_window_maximized YES ウィンドウを[最大サイズで開く]
override_store_back no
別のディレクトリから読み込んだオブジェクトを現在のワーキングディレクトリに保存[しない]
number_user_colors 256 [256色]のユーザカラーを使用可能にする。
! number_wireframe_colors 256
ワイヤフレームで[256色]のユーザカラーを使用可能にする。
Wildfire 1.0 以降 - 無効となります。
package_ref_alert YES パッケージ構成部品への参照を[警告する]
parenthesize_ref_dim YES 参照寸法を[括弧内に表示する]
pdf_use_pentable YES
PDF へ出力する際にペンテーブルファイル(table.pnt)を [使用する]
Wildfire 3.0 以降 - 常にモノクロで出力する場合はペンテーブルファイル内でペンの色を黒に指定します。[color 0.0 0.0 0.0]
table.pnt の設定例 : pen 1 thickness 0.02 cm; color 0.0 0.0 0.0; drawing_color
詳細は設定ファイル内の[table.pnt]をメモ帳等で開いて確認してください。
! pick_aperture_radius 7 選択時のマウス周辺サイズを[7]とする。(スクリーンサイズの 1/1000 で指定)
plotter DEFAULT プロッターを デフォルト に指定する。
plot_names YES プロット・ファイルに拡張子を つける。
prehighlight yes
選択前ハイライトを[有効にする]
Wiidfire 1.0 以降
prompt_on_exit YES
終了時にファイルを保存するかどうか[問い合わせる]
今までは[no]に設定していましたが、[YES]に変更しました。しばらくこれで運用してみます。
protable_in_background yes Pro/TABLE エディタを[バックグラウンドで起動する]
provide_pick_message_always YES 選択したアイテムについてのメッセージを[常に表示する]
pro_unit_length UNIT_MM デフォルト単位を[mm]にする。
pro_unit_mass UNIT_GRAM デフォルト単位を[gr]にする。
! query_bin_start NO
順次選択リストを[表示しない]
PROVIDE_PICK_MESSAGE_ALWAYS Yes の設定と併用すれば、順次選択リストを表示しなくても大丈夫です。
Wildfire 1.0 以降 - 無効になります。順次選択モードにすると、必ず順次選択リストが表示されます。
regen_solid_before_save YES
モデルを保存する際、トップモデルおよびモデルの未再生フィーチャを[再生する] 変更されていないフィーチャは再生されません。保存時に未再生プロンプトは表示されません。
Creo 1.0 以降 - 未再生状態のモデルデータを保存する際の動作に関する設定です。デフォルトの設定は[prompt]です。モデルが再生されていない旨のプロンプトが表示されますが、[OK]で未再生状態でも保存できます。
[NO]
モデルは未再生のまま保存されます。
[FORCE]
Creo 2.0 M140 および Creo 3.0 M040 以降追加された設定値。モデルの全フィーチャを強制的に再生しますので、変更されていないフィーチャも再生されることに留意してください。
relation_file_editor PROTAB リレーション編集に[Pro/TABLE]を使用する。
rename_drawings_with_object BOTH
部品およびアセンブリ[両方のモードで]関連する図面を同時にコピーする。
部品およびアセンブリと図面のファイル名が同一であることが条件です。
reserved_menu_space 1
右側のメニュースペースを[1]に指定する
Pro/E 2001 以前 - 設定値は[2]が最適です。
Wildfire 1.0 以降 - 設定値は[1]が最適です。
! save_display YES 表示専用モードで図面を読み込む際に必要な画像情報を保存[する]
save_drawing_picture_file EMBED
製図を保存する時に画像情報を[埋め込む]
Pro/E 2000i 以降 - 保存された図面[.drw]ファイルを直接 ProductView で見ることができます。
Pro/E 20 - [Yes] に設定すると、拡張子[.pic]の画像ファイルが作成され、ProductView で見ることができます。
save_model_display shading_lod
モデルを保存する時に[シェーディング情報も保存する]
Pro/E 18 以降 - 保存された[.prt]ファイルをプレビューしたり、ProductView などで見ることが出来ます。
save_objects changed_and_specified [最上位と修正を行なった依存オブジェクト]を保存する。
save_triangles_flag YES ...
selection_of_removed_entities YES エッジ表示メニューで2次元断面の前にあるエンティティを[削除・クリップ・消去できる]
shade_surface_feat yes サーフェス・フィーチャーをシェーディング[する]
shade_quality 7
シェーディングの品質を[7]にする。
Creo 1.0 以降 - 最大値は 50 に変更されていますが、設定値を過大に設定するとパフォーマンスが悪くなりますので注意してください。私の推奨値[7]くらいでも実用上は十分です。
Wildfire 5.0 以降 - 数字を大きく(最大は 10)すれば、シェーディングの品質はよくなりますが、パフォーマンスは悪くなります。
show_axes_for_extr_arcs YES 円弧を作成した時に軸を[表示する]
show_geom_checks_on_creation YES ジオメトリ・チェックがあれば[エラーメッセージを表示する]
show_preview_default remove
「表示および消去」メニューのデフォルトを[非選択]とする。
Creo 以降 - [remove]指定で、全アイテム非表示がデフォルト、選択したアイテムのみが表示されます。
Wildfire 以前 - [KEEP]指定で、全アイテム非表示がデフォルト、選択したアイテムのみが表示されます。
show_shaded_edges YES
シェーディング表示の時にエッジを強調表示[する]
Creo 1.0 以降 - エッジ付きシェーディング表示が可能になったので?削除されました。
single_side_surf_color YES
サーフェスの片側(表面/裏面)に個別の外観色の設定を[許可する]
Creo 1.0 以降 - デフォルトでは[no]になっているため、サーフェスの片側(表面/裏面)に個別に外観色を設定できません。個別に外観色を設定する際は[Alt]キーを押しながらサーフェスを選択します。
! sketcher_dec_places 3
スケッチャーの小数桁数を[3桁]にする。
Wildfire 5.0 以降 - 無効になったようです。
sketcher_dim_of_revolve_axis NO
インテントマネージャで回転軸に作成される寸法を直径寸法に [しない]
Wildfire 5.0 以降 - デフォルト値が直径寸法[yes]になっています。
Wildfire 4.0 以前 - デフォルト値が通常寸法[no]になっています。
sketcher_disp_grid YES スケッチャーのグリッドを 「表示する」
sketcher_highlight_open_ends yes
スケッチャーでスケッチエンティティのオープンエンドを[ハイライトする]
Creo 1.0 以降 - sketcher_shade_closed_loops を [NO] にしても、閉じてないループは発見できます。
! sketcher_intent_manager yes
スケッチャーのダイナミックマネージャを[使用する]
スペックの低いマシンではレスポンスが悪くなるので、その場合は[NO]にして下さい。
! sketcher_overview_alert NO
スケッチャー開始時、ダイナミックマネージャの説明を[表示しない]
Pro/E 2000i2 - スケッチャ開始時の余計なお世話を消すことができます。
! sketcher_readme_button NO
スケッチャー開始時、ダイナミックマネージャの説明を[表示しない]
Pro/E 20 - スケッチャ開始時の余計なお世話を消すことができます。
sketcher_shade_closed_loops NO
スケッチャーで閉じたループを[シェード表示しない]
Creo 1.0 以降 - sketcher_highlight_open_ends がデフォルト[ yes] になっていれば、閉じていないループは発見できますので、あえて表示しなくてもよいと思います。
sketcher_starts_in_2d no
スケッチを[3D方向]で開始する。
Creo 4.0 以降 - スケッチを3D方向で開始する設定[no]を試しています。Pro/E のスケッチャーに慣れたユーザは[YES]に設定したほうがいいかもしれません。
Creo 1.0 以降 - デフォルト値が3D方向[no]になっています。
Wildfire 5.0 以前 - デフォルト値が2D方向[yes]になっています。
sketch_background_color MANUAL
3Dモデルの寸法背景色を[手動]で設定する。
Creo 8.0 以降 - スケッチ寸法の背景色をRGB値で設定します。
sketch_background_color_rgb
255 255 255
スケッチ寸法の背景色を白[255 255 255]とする。
Creo 8.0 以降 - スケッチ寸法の背景色をRGB値で指定します。
sketch_dim_background_trans 25
スケッチ寸法の背景色を透明度[25]とする。
Creo 8.0 以降 - スケッチ寸法の背景色を設定できるようになったのに伴い、透明度も指定できるようになりました。
spin_center_display NO スピン中心を[表示しない]
spin_rate_zoom_sensitive YES ズームイン時はスピンを[スローにする]
spin_with_notes NO スピン時にモデル注記を[表示しない]
spin_with_part_entities YES スピン時にデータム平面を[表示する]
spin_with_silhouettes no スピン時にシルエットエッジを[表示しない]
startup_check_for_visualization NO
起動時にビジュアリアリゼーションコンポーネント(下図)のインストールを[確認しない]
Wildfire 5.0 以降 - デフォルトは[yes]になっています。
step_export_format AP214_IS
STEP を[AP214_IS]フォーマットでエクスポートします。
Creo 3.0 以前 - デフォルトは[ap203_is]となっていますので、それ以外のフォーマットで出力したいときは config.pro で指定する必要があります。
Creo 4.0 以降 - STEP をエクスポートする際に出力フォーマットを選択できます。ここで指定した値は選択肢のデフォルトになります。
! system_background_color 0 25 50 メイン画面の背景色を[RGB]の比率で指定する。
tangent_edge_display PHANTOM
正接サーフェス間のエッジを[二点鎖線]で表示する。
画面表示に若干負担をかけますが、正接エッジの確認がしやすくなる。
text_height_factor 60
グラフィックウィンドウ内に表示される文字の大きさを変更します。デフォルトは[70]ですが、老眼等で見にくい場合は[60]などにします。
このオプションは隠し設定です。数字は 0〜100 の間で指定します。70よりも小(大きな)さな値を指定すると文字が大きく(小さく)なります。私は[60]くらいが見やすいと思います。
 
 デフォルト[70]      [60]         [50]
  
! thermo_position_hint NO_WINDOW_OVERLAP 温度計スケールを Pro/E ウィンドウと[重ねない]
todays_date_note_format %yyyy.%mm.%dd 図面に表示する日付のフォーマット[%yyyy.%mm.%dd]
tolerance_class fine ISO公差規格のデフォルトに[精密級]を使用する。
tolerance_standard ISO 公差規格に[ISO]を使用する。
tol_display no モデル内で寸法を[公差なし]で表示します。
tol_mode NOMINAL 寸法公差のデフォルト表示を[公差なし(基準値)]にする。
use_8_plotter_pens YES
プロッタで最大8本までのペンを[使用可能]
デフォルトでは 4本まで。
use_iges_kanji_font_2001 YES エクスポート時にPro/Eの漢字注記IGESの漢字注記に[変換する]
variable_plots_in_inches NO 可変プロットサイズを[mm]で入力する。
variant_drawing_item_sizes YES 製図シートサイズの変更時、アイテムのサイズと位置を[保つ]
visible_mapkeys no マップキーを実行する時、メニューを[表示しない]
visible_message_lines 2 メッセージ・ウインドウの表示行数を[2行]にする。
vrml_file_duplicate_material YES VRMLファイルにモデルのカラーを[反映する]
windows_scale 1.0 ウインドウの大きさを[100%]にする。
www_export_geometry_as ALL [全ての形状]をVRMLファイルに書き込む。
www_multiple_views ALL 全ての構成部品の[全ビュー]をVRMLファイルに書き込む。
! -- Mapkeys --
最低限のマップキーです。作りすぎても、覚えきれないし、メンテナンスが大変です。「!」マークはコメント行です。
! Purge Directory(pg - ワーキングディレクトリ全体をパージします)
mapkey pg @MAPKEY_LABELPurge Dir;@SYSTEMpurge;
! Regenerate(rg - モデルを再生します)
mapkey rg @MAPKEY_LABELReGenerate;#REGENERATE;#AUTOMATIC;
! Repaint(rr - 画面を再描画します)
mapkey rr @MAPKEY_LABELRRepaint;#view;#repaint;#done-return;
! View Default(vv - ビューの向きをデフォルト方向=システム標準方向にします)
mapkey vv @MAPKEY_LABELdefault VView;#view;#default;#done-return;

Wildfire 以降
! View Default(vv - ビューの向きをユーザデフォルト方向にします。システム標準方向とは別になります)
mapkey vv @MAPKEY_NAMERotate View Default;@MAPKEY_LABELVView default;\
mapkey(continued) ~ Command `ProCmdViewNamePick` 1 ;\
mapkey(continued) ~ Select `nameviewlist` `nv_list`1 `Default`;

Creo 以降
! View Default(vv - ビューの向きをユーザデフォルト方向にします。システム標準方向とは別になります)
mapkey vv @MAPKEY_NAMERotate View Default;@MAPKEY_LABELVView default;\
mapkey(continued) ~ Select `main_dlg_cur` \
mapkey(continued) `igToolbar_AncestorIGT_IGT_GRP_inh396938342.proe_win:casc340798662`;\
mapkey(continued) ~ Close `main_dlg_cur` \
mapkey(continued) `igToolbar_AncestorIGT_IGT_GRP_inh396938342.proe_win:casc340798662`;\
mapkey(continued) ~ Command `ProCmdNamedViewsGalSelect` `Default`;
! Center of Gravity Part(cp - 部品の質量特性を計算し、重心位置に点 PNT_CG を移動します)
mapkey cp @MAPKEY_NAMECenter of Gravity Part;@MAPKEY_LABELCg Prt;\
mapkey(continued) ~ Close `main_dlg_cur` `appl_casc`;~ Command `ProCmdMmModelProperties` ;\
mapkey(continued) ~ Activate `mdlprops_dlg` `MASS_PROPS_lay_Controls.push_Change.lay_instance`;\
mapkey(continued) ~ Activate `mass_prop_dlg` `CalculateMPPush`;\
mapkey(continued) ~ Activate `mass_prop_dlg` `OkPush`;\
mapkey(continued) ~ Activate `mdlprops_dlg` `DlgClose_push`;~ Command `ProCmdRegenPart`;
! Center of Gravity Assembly(ca - アセンブリの質量特性を計算し、重心位置に点 APNT_CG を移動します)
mapkey ca @MAPKEY_NAMECenter of Gravity Assembly;@MAPKEY_LABELCg Asm;\
mapkey(continued) ~ Close `main_dlg_cur` `appl_casc`;~ Command `ProCmdMmModelProperties` ;\
mapkey(continued) ~ Activate `mdlprops_dlg` `MASS_PROPS_lay_Controls.push_Change.lay_instance`;\
mapkey(continued) ~ Activate `mass_prop_dlg` `CalculateMPPush`;\
mapkey(continued) ~ Activate `mass_prop_dlg` `OkPush`;\
mapkey(continued) ~ Activate `mdlprops_dlg` `DlgClose_push`;~ Command `ProCmdRegenAuto`;
! System Color custom(sc - システムカラーをカスタム設定にします)
mapkey sc @MAPKEY_NAMEChange System Color to Custom;\
mapkey(continued) @MAPKEY_LABELSyscol Custom;~ Select `main_dlg_cur` `appl_casc`;\
mapkey(continued) ~ Close `main_dlg_cur` `appl_casc`;~ Command `ProCmdRibbonOptionsDlg` ;\
mapkey(continued) ~ Select `ribbon_options_dialog` `PageSwitcherPageList` 1 `colors_layouts`;\
mapkey(continued) ~ Open `ribbon_options_dialog` `colors_layouts.Color_scheme_optMenu`;\
mapkey(continued) ~ Close `ribbon_options_dialog` `colors_layouts.Color_scheme_optMenu`;\
mapkey(continued) ~ Select `ribbon_options_dialog` `colors_layouts.Color_scheme_optMenu` 1 \
mapkey(continued) `Custom`;~ Activate `ribbon_options_dialog` `OkPshBtn`;
! System color White(sw - システムカラーを白に黒をかぶせる設定にします)
mapkey sw @MAPKEY_NAMEChange System Color to Black and White;\
mapkey(continued) @MAPKEY_LABELSyscol White;~ Select `main_dlg_cur` `appl_casc`;\
mapkey(continued) ~ Close `main_dlg_cur` `appl_casc`;~ Command `ProCmdRibbonOptionsDlg` ;\
mapkey(continued) ~ Select `ribbon_options_dialog` `PageSwitcherPageList` 1 `colors_layouts`;\
mapkey(continued) ~ Open `ribbon_options_dialog` `colors_layouts.Color_scheme_optMenu`;\
mapkey(continued) ~ Close `ribbon_options_dialog` `colors_layouts.Color_scheme_optMenu`;\
mapkey(continued) ~ Select `ribbon_options_dialog` `colors_layouts.Color_scheme_optMenu` 1 `2`;\
mapkey(continued) ~ Activate `ribbon_options_dialog` `OkPshBtn`;
! Grid Snap on(gs - グリッドスナップを ON にします)
mapkey gs @MAPKEY_NAMEGrid Snap on;@MAPKEY_LABELGrid Snap;~ Command `ProCmdRibbonOptionsDlg` ;\
mapkey(continued) ~ Select `ribbon_options_dialog` `PageSwitcherPageList` 1 `sketch_layouts`;\
mapkey(continued) ~ Activate `ribbon_options_dialog` `sketch_layouts.grid_snap.lay_instance` 1;\
mapkey(continued) ~ Activate `ribbon_options_dialog` `OkPshBtn`;\
mapkey(continued) ~ FocusIn `UITools Msg Dialog Future` `no`;\
mapkey(continued) ~ Activate `UITools Msg Dialog Future` `no`;
! Grid Snap off(gf - グリッドスナップを OFF にします)
mapkey gf @MAPKEY_NAMEGrid Snap off;@MAPKEY_LABELGrid snap ofF;\
mapkey(continued) ~ Command `ProCmdRibbonOptionsDlg` ;\
mapkey(continued) ~ Select `ribbon_options_dialog` `PageSwitcherPageList` 1 `sketch_layouts`;\
mapkey(continued) ~ Activate `ribbon_options_dialog` `sketch_layouts.grid_snap.lay_instance` 0;\
mapkey(continued) ~ Activate `ribbon_options_dialog` `OkPshBtn`;\
mapkey(continued) ~ FocusIn `UITools Msg Dialog Future` `no`;\
mapkey(continued) ~ Activate `UITools Msg Dialog Future` `no`;
! Printer Setting PDF A3(d3 - 印刷設定を PDF A3 にします)
mapkey d3 @MAPKEY_NAMEPrinter Setting PDF A3;@MAPKEY_LABELpDf a3;\
mapkey(continued) ~ Command `ProCmdViewRefit` ;~ Close `main_dlg_cur` `appl_casc`;\
mapkey(continued) ~ Command `ProCmdModelPrint` ;~ Command `ProCmdDwgPubSettings` ;\
mapkey(continued) ~ Select `dwg_print_config` `CascadeButton1`;\
mapkey(continued) ~ Close `dwg_print_config` `CascadeButton1`;\
mapkey(continued) ~ Activate `dwg_print_config` `PDF A3 OFFSET 6mm`;\
mapkey(continued) ~ Activate `dwg_print_config` `OK`;

Home Copyright (C) 1997 - 2024 龍菜 Ryu-na Design and Engineering
All rights reserved.
User PageKnow-how